Spring AMQP
  1. Spring AMQP
  2. AMQP-195

Upgrade to 2.6.x version of the RabbitMQ Java client

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Complete
    • Affects Version/s: None
    • Fix Version/s: 1.1.0.GA
    • Component/s: None
    • Labels:
      None

      Description

      Not 100% sure that we can do this for 1.0.1 since we need to consider backwards compatibility, but I am setting that as the target version at least while we explore the possibility.

        Issue Links

          Activity

          Hide
          Dave Syer added a comment -

          What is the benefit to the user of upgrading the Rabbit Java client? What broker versions are supported by the Java client 2.5.*? (I have tried it with 2.4, 2.5 and 2.6 and had no problems, but I didn't push the envelope exactly.)

          Show
          Dave Syer added a comment - What is the benefit to the user of upgrading the Rabbit Java client? What broker versions are supported by the Java client 2.5.*? (I have tried it with 2.4, 2.5 and 2.6 and had no problems, but I didn't push the envelope exactly.)
          Hide
          Matthias Reik added a comment -
          Show
          Matthias Reik added a comment - Regarding v2.5 and 2.6 are not compatible, see my comment here: http://forum.springsource.org/showthread.php?116222-Please-publish-which-versions-of-Rabbit-are-compatible-with-Spring-AMQP
          Hide
          Justin Miller added a comment -

          Dave, I think Matthias slightly misunderstood your question. I believe this is what you were asking:

          https://groups.google.com/forum/#!msg/rabbitmq-discuss/veGfLfW9VBc/O-BNMCtiTAkJ

          Show
          Justin Miller added a comment - Dave, I think Matthias slightly misunderstood your question. I believe this is what you were asking: https://groups.google.com/forum/#!msg/rabbitmq-discuss/veGfLfW9VBc/O-BNMCtiTAkJ
          Hide
          james r. carr added a comment -

          FYI, This should probably now be upgraded to the 2.7.1 client. Essentially, using the latest 2.x.x client ensures certain bug fixes in the client while keeping interop with any brokers >= 2.0.0.

          Show
          james r. carr added a comment - FYI, This should probably now be upgraded to the 2.7.1 client. Essentially, using the latest 2.x.x client ensures certain bug fixes in the client while keeping interop with any brokers >= 2.0.0.
          Hide
          Gary Russell added a comment -

          PR Issued: https://github.com/SpringSource/spring-amqp/pull/16

          Updates client to 2.7.1.

          Show
          Gary Russell added a comment - PR Issued: https://github.com/SpringSource/spring-amqp/pull/16 Updates client to 2.7.1.
          Hide
          Gary Russell added a comment -

          Tested PR with 2.8.0 client - no API changes.

          Show
          Gary Russell added a comment - Tested PR with 2.8.0 client - no API changes.

            People

            • Assignee:
              Gary Russell
              Reporter:
              Mark Fisher
            • Votes:
              5 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: