Spring for Android
  1. Spring for Android
  2. ANDROID-61

RestTemplate HttpAccessor seems to be leaking threads

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.0.0.M4
    • Fix Version/s: 1.0.0.RC1
    • Component/s: rest-template
    • Labels:
      None

      Description

      See forum reference for details.

        Activity

        Roy Clarkson added a comment -

        This is related to ANDROID-54. Prior to Froyo (2.2), the Apache Http client was recommended, but newer versions should probably be using HttpUrlConnection because of the improvements made to it. Spring Android still needs to support Android 2.1, so one option is to load the apache client for 2.1, and HttpUrlConnection client for 2.2 and newer versions.

        Roy Clarkson added a comment -

        I've done a lot of testing and all the threads spawned from the Apache Http Components client seem to be released after a short time. I did not experience a force close when creating 1000 threads, and eventually all the threads were returned to the pool.


          People

          • Assignee:
            Roy Clarkson
            Reporter:
            Roy Clarkson
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: