Uploaded image for project: 'Spring for Android'
  1. Spring for Android
  2. ANDROID-80

RestTemplate cannot read response from HTTP 401 not authorized

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 1.0.0.RC1
    • Fix Version/s: 1.0.0.RELEASE
    • Component/s: rest-template
    • Labels:
      None

      Description

      Similar to ANDROID-57

        Activity

        rclarkson Roy Clarkson added a comment -

        The root cause of this may be ANDROID-89.

        rclarkson Roy Clarkson added a comment -

        The issue fixed in ANDROID-89 seems to have resolved this. HTTP 401 responses are now handled consistently across all HTTP clients, throwing an HttpClientErrorException. The exception is thrown prior to the data extraction.


          People

          • Assignee:
            rclarkson Roy Clarkson
            Reporter:
            rclarkson Roy Clarkson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: