Spring Batch
  1. Spring Batch
  2. BATCH-1386

Expose throttle-limit for the chunk element in the namespace/schema.

    Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.0.3
    • Fix Version/s: None
    • Component/s: Core
    • Labels:
      None

      Description

      Expose a throttle-limit for the chunk element when used with taskExecutor to have an upper limit of concurrent executing threads.
      This way several chunks (or other services) can share a threadpool, but it's possible to have more control over it's usage.

        Activity

        Dave Syer added a comment -

        Looks like a duplicate of BATCH-1216 which was fixed in 2.0.1, so the feature should already be there.

        David J. M. Karlsen added a comment -

        Well, what can I say - If you check the schema it's not there: http://www.springframework.org/schema/batch/spring-batch-2.0.xsd

        David J. M. Karlsen added a comment -

        Ah - but it is in the distribution.
        Update the published schema?

        Dave Syer added a comment -

        Try again now (clear your browser cache if you are using one).


          People

          • Assignee:
            Unassigned
            Reporter:
            David J. M. Karlsen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: