Uploaded image for project: 'Spring Data for Apache Cassandra'
  1. Spring Data for Apache Cassandra
  2. DATACASS-655

Eliminate a vulnerability of DataStax Cassandra driver

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.5.21 (Ingalls SR21), 2.0.14 (Kay SR14), 2.1.7 (Lovelace SR7), 2.2 M3 (Moore)
    • Fix Version/s: None
    • Component/s: Infrastructure
    • Labels:
      None
    • Last commented by a User:
      true

      Description

      DataStax Cassandra driver have a vulnerability which causes from Google Guava library.

      https://github.com/google/guava/wiki/CVE-2018-10237

       

      We have to use the driver version 4.x.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mp911de Mark Paluch
              Reporter:
              tsasaki609 tsasaki609
              Last updater:
              Mark Paluch
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 17 weeks, 6 days ago