Uploaded image for project: 'Spring Data Commons'
  1. Spring Data Commons
  2. DATACMNS-1272

java.lang.ClassNotFoundException: org.springframework.data.mapping.model.MappingException

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Works as Designed
    • Affects Version/s: 2.0.5 (Kay SR5)
    • Fix Version/s: None
    • Component/s: Core
    • Labels:
      None

      Description

      Looking at the spring-data-commons-1.13.10.RELEASE vs spring-data-commons-2.0.5.RELEASE, it looks like MappingException class has been moved from org.springframework.data.mapping.model.MappingException to org.springframework.data.mapping.MappingException which causes lots of applications to fail if they have any dependency on spring-data-commons older than 2.0.x

      Currently I want to test Spring Boot 2.0.0.RC2 but I'm adding a library that has a dependency on spring-data-commons-1.13.10.RELEASE, and on loading context I get the following exception:

      Caused by: java.lang.ClassNotFoundException: org.springframework.data.mapping.model.MappingException
      	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
      	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      

        Attachments

          Activity

            People

            • Assignee:
              olivergierke Oliver Drotbohm
              Reporter:
              amellice Akram
              Last updater:
              Oliver Drotbohm
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: