Uploaded image for project: 'Spring Data MongoDB'
  1. Spring Data MongoDB
  2. DATAMONGO-545

Add before delete and after delete events for AbstractMongoEventListener

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3 M1
    • Component/s: Repository
    • Labels:

      Description

      It would be useful in certain cases to have AbstractMongoEventListener provide onBeforeDelete(…) and onAfterDelete(…) methods so event listeners could take appropriate action.

        Issue Links

          Activity

          nsudan Nikita Sudan added a comment -

          This feature would be super useful. Any updates on this ticket? Has this already been resolved?

          baumgartner Martin Baumgartner added a comment -

          Tried to solve this, beforeDelete and AfterDelete should be called on delete, but not at removeAll.

          See: https://github.com/SpringSource/spring-data-mongodb/pull/30

          jasone Jason Eacott added a comment -

          this seems to be a duplicate of DATAMONGO-267


            People

            • Assignee:
              olivergierke Oliver Gierke
              Reporter:
              d3xt3r Scott Rossillo
              Last updater:
              Trevor Marshall
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: