Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0.M2
    • Fix Version/s: 1.0.0.RC2
    • Component/s: None
    • Labels:
      None

      Description

      The schema referenced in the documentation <http://static.springframework.org/spring-flex/docs/1.0.x/reference/html/ch02s03.html> is not present at <http://www.springframework.org/schema/flex/spring-flex-1.0.xsd>. In fact, the entire 'flex' directory is missing.

        Activity

        Jerry Carter added a comment -

        NOTE: I realize that the documentation covers this: "Note that until the final xsd is published to the above web address, you would need to manually add the XSD to your XML catalog in Eclipse for auto-completion to work correctly."

        Jeremy Grelle added a comment -

        We will not publish the schema at the web address until the final 1.0 release (past experience shows that publishing early can cause problems). It is easily accessible in the distribution (in the source under projects/org.springframework.flex/src/main/java/org/springframework/flex/messaging/config/xml/spring-flex-1.0.xsd) and this should be adequate until then.

        Mark Fisher added a comment -

        Here are the instructions for adding the XSD to the XML Catalog in Eclipse:

        1) go to: Preferences -> (Web and) XML -> XML Catalog

        2) Then choose "Add..." and provide the following...

        Location: select 'Workspace...' from the dropdown on the right and browse to the XSD location (or just add "org.springframework.flex/src/main/java/org/springframework/flex/messaging/config/xml/spring-flex-1.0.xsd")

        Key Type: Schema Location

        Key: http://www.springframework.org/schema/flex/spring-flex-1.0.xsd

        Senthur Shanmugalingm added a comment -

        I am using tomcat to run my Spring Blaze Integration example. When deployed, I am getting an error stating:

        org.springframework.beans.factory.xml.XmlBeanDefinitionStoreException: Line 12 in XML document from ServletContext resource [/WEB-INF/web-application-config.xml] is invalid; nested exception is org.xml.sax.SAXParseException: cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'flex:message-broker'.
        Caused by: org.xml.sax.SAXParseException: cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'flex:message-broker'.

        My Application config file (web-application-config.xml) has an entry like the following;

        <beans xmlns="http://www.springframework.org/schema/beans"
        xmlns:flex="http://www.springframework.org/schema/flex"
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:schemaLocation="
        http://www.springframework.org/schema/beans
        http://www.springframework.org/schema/beans/spring-beans-2.5.xsd
        http://localhost:8080/schemas/
        http://localhost:8080/schemas/spring-flex-1.0.xsd">

        where http://localhost:8080/schemas/, contains the spring-flex-1.0.xsd

        Senthur Shanmugalingm added a comment -

        Sorry for the previous comment.

        When deploying the application you have to specify the xsi:schemaLocation as;
        http://www.springframework.org/schema/flex
        http://www.springframework.org/schema/flex/spring-flex-1.0.xsd"

        It works fine.

        the previous comment is only applicable for auto complete functionality.


          People

          • Assignee:
            Jeremy Grelle
            Reporter:
            Jerry Carter
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: