Spring BlazeDS Integration
  1. Spring BlazeDS Integration
  2. FLEX-65

Ensure compatability with Spring Security 3.0

    Details

    • Type: Refactoring Refactoring
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.5.0.M1
    • Component/s: None
    • Labels:
      None

      Description

      Due to Spring Security 3.0 using a re-organized package structure, it breaks the security integration features of Spring BlazeDS Integration 1.0

        Activity

        Hide
        Kudos Ltda. added a comment -

        I'm having the same issue.

        I'm trying to use spring blazeds integration 1.0 with spring-framework-3.0.0.M4 , spring-security-3.0.0.M2 and Hibernate 3.3.0 but It seems that there is an incompatibility between blazeds integration 1.0 and spring-security-3.0.0.M2:

        Error creating bean with name '_messageBrokerLoginCommand': Resolution of declared constructors on bean Class [org.springframework.flex.security.SpringSecurityLoginCommand] from ClassLoader [WebappClassLoader]

        Caused by: java.lang.ClassNotFoundException: org.springframework.security.Authentication

        Show
        Kudos Ltda. added a comment - I'm having the same issue. I'm trying to use spring blazeds integration 1.0 with spring-framework-3.0.0.M4 , spring-security-3.0.0.M2 and Hibernate 3.3.0 but It seems that there is an incompatibility between blazeds integration 1.0 and spring-security-3.0.0.M2: Error creating bean with name '_messageBrokerLoginCommand': Resolution of declared constructors on bean Class [org.springframework.flex.security.SpringSecurityLoginCommand] from ClassLoader [WebappClassLoader] Caused by: java.lang.ClassNotFoundException: org.springframework.security.Authentication
        Hide
        Stéphane Nicoll added a comment -

        Is there any schedule for this one?

        Show
        Stéphane Nicoll added a comment - Is there any schedule for this one?
        Hide
        Fedja Nikolic added a comment -

        Any updates on this one?

        Show
        Fedja Nikolic added a comment - Any updates on this one?
        Hide
        Simon Wiesen added a comment -

        Spring BlazeDS Integration 1.0.1 is not compatible with Spring 3.0 (see Spring Security 3.0).
        It would be great if this can be fixed in Version 1.0.2

        Show
        Simon Wiesen added a comment - Spring BlazeDS Integration 1.0.1 is not compatible with Spring 3.0 (see Spring Security 3.0). It would be great if this can be fixed in Version 1.0.2
        Hide
        Jeremy Grelle added a comment -

        Spring Security 3 support is provided via the new org.springframework.flex.security3 package. Support for Spring Security 2.x is still available as well in the original org.springframework.flex.security package. Both are available in the same spring-flex jar, and the XML namespace config mechanism will automatically detect the version of Spring Security that is available on the classpath and install the appropriate supporting beans.

        Show
        Jeremy Grelle added a comment - Spring Security 3 support is provided via the new org.springframework.flex.security3 package. Support for Spring Security 2.x is still available as well in the original org.springframework.flex.security package. Both are available in the same spring-flex jar, and the XML namespace config mechanism will automatically detect the version of Spring Security that is available on the classpath and install the appropriate supporting beans.
        Hide
        Fedja Nikolic added a comment -

        When can we expect a new release or a nightly snapshot?
        Is this where I should be looking at?
        http://static.springsource.org/downloads/nightly/snapshot-download.php?project=FLEX

        Show
        Fedja Nikolic added a comment - When can we expect a new release or a nightly snapshot? Is this where I should be looking at? http://static.springsource.org/downloads/nightly/snapshot-download.php?project=FLEX
        Hide
        Jeremy Grelle added a comment -

        Yes, the latest one is here:
        http://s3.amazonaws.com/dist.springframework.org/snapshot/FLEX/spring-flex-1.0.2.CI-22.zip

        Final release of 1.0.2 should be coming very soon.

        Show
        Jeremy Grelle added a comment - Yes, the latest one is here: http://s3.amazonaws.com/dist.springframework.org/snapshot/FLEX/spring-flex-1.0.2.CI-22.zip Final release of 1.0.2 should be coming very soon.

          People

          • Assignee:
            Jeremy Grelle
            Reporter:
            Jeremy Grelle
          • Votes:
            11 Vote for this issue
            Watchers:
            14 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: