Spring IDE
  1. Spring IDE
  2. IDE-1134

Error installing into 2.3.3m2 Springsource grails extension without installing groovy-eclipse first

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.2
    • Fix Version/s: 2.5.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      Ubuntu, 64-bit, JDK 1.6.0-20

      Description

      On a fresh download, fresh workspace, trying to install grails support from springsource via the extension mechanism fails. The error given is a missing file on the server. Further analysis shows its actually a missing dependency... the groovy-eclipse codehaus extension.

      By installing the groovy-eclipse extension, I can then install the grails extension from springsource.

      What to fix: Either fix dependency tracking so the proper extension is installed automatically or document this somewhere.

        Activity

        Hide
        Ned Wolpert added a comment -

        BTW, I had to say 'affects version 2.3.2... would be good if 2.3.3 was in the list I could pick from

        Show
        Ned Wolpert added a comment - BTW, I had to say 'affects version 2.3.2... would be good if 2.3.3 was in the list I could pick from
        Hide
        Christian Dupuis added a comment -

        This has been fixed in the STS extension install listing.

        Christian

        Show
        Christian Dupuis added a comment - This has been fixed in the STS extension install listing. Christian

          People

          • Assignee:
            Christian Dupuis
            Reporter:
            Ned Wolpert
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: