Spring IDE
  1. Spring IDE
  2. IDE-1262

STS/GGTS 3.1 not running with JDK7 on OS X

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Works as Designed
    • Affects Version/s: 3.1.0.RELEASE
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      MacOS X 10.8.2

      Description

      When trying to start GGTS 3.x (my 3.1 is currently an upgraded 3.0) on OS X with JDK 7 I get the following error

      The JVM shared library "/Library/Java/JavaVirtualMachines/jsk1.7.0_10.jdk" does not contain the JNI_CreateJavaVM symbol.

      In the background (if opened from a Terminal) the application claims:

      /Applications/springsource/ggts-3.0.0.RELEASE/GGTS.app/Contents/MacOS/GGTS ; exit;
      Unable to find any JVMs matching architecture "i386".
      2012-10-09 10:38:40.420 GGTS[9431:707] Error loading /Library/Java/JavaVirtualMachines/jdk1.7.0_10.jdk/Contents/MacOS/libjli.dylib: dlopen(/Library/Java/JavaVirtualMachines/jdk1.7.0_10.jdk/Contents/MacOS/libjli.dylib, 265): no suitable image found. Did find:
      /Library/Java/JavaVirtualMachines/jdk1.7.0_10.jdk/Contents/MacOS/libjli.dylib: mach-o, but wrong architecture

      As requested by Andy Clement: It is not possible to start GGTS with the -d32 flag since JDK7 for MacOS is only available as 64bit release:

      $ JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.7.0_10.jdk/Contents/Home java -d32
      Error: This Java instance does not support a 32-bit JVM.

      Cf. http://jdk7.java.net/downloads

      And yes, I am using SubClipse (1.8.6) ... but I do not think this part of the primary issue since GGTS does not even start to load (due to the dylib issue!).

        Activity

        Martin Lippert added a comment -

        Yepp, the JDK7 from Oracle is 64bit only for OSX. So are you sure you have downloaded and installed the 64bit version of GGTS? It looks a bit like GGTS is trying to find an environment for a 32bit architecture which it cannot find for JDK7, therefore I am guessing there is an 32bit version of GGTS trying to startup... Can you check that?

        Gerd Aschemann added a comment -

        Of course, you are right: I was just trying to use the 32bit GGTS with the 64bit JVM ... sorry!

        Martin Lippert added a comment -

        No problem, glad we found the problem.


          People

          • Assignee:
            Martin Lippert
            Reporter:
            Gerd Aschemann
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: