Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.2.2
    • Component/s: beans.core
    • Labels:
      None

      Description

      – Error Details –
      Date: Sat Jan 31 16:56:15 PST 2009
      Message: Internal Error
      Severity: Error
      Plugin: org.springframework.ide.eclipse.beans.core
      Session Data:
      eclipse.buildId=M20080911-1700
      java.version=1.5.0_17
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
      Framework arguments: -keystore /home/lindholm/.eclipsekeystore
      Command-line arguments: -os linux -ws gtk -arch x86 -keystore /home/lindholm/.eclipsekeystore -data /local/src/workspace

      Exception Stack Trace:
      org.springframework.beans.factory.BeanDefinitionStoreException: IOException parsing XML document from file [/home/lindholm/Documents/kns/src/main/resources/org/kuali/core/document/datadictionary/UniversalUserMaintenanceDocument.xml!kns/src/main/resources/org/kuali/core/document/datadictionary/UniversalUserMaintenanceDocument.xml]; nested exception is java.io.IOException: error in opening zip file
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:349)
      at org.springframework.ide.eclipse.beans.core.internal.model.BeansConfig$2.loadBeanDefinitions(BeansConfig.java:333)
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:310)
      at org.springframework.ide.eclipse.beans.core.internal.model.BeansConfig$3.call(BeansConfig.java:365)
      at org.springframework.ide.eclipse.beans.core.internal.model.BeansConfig$3.call(BeansConfig.java:1)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      at java.util.concurrent.FutureTask.run(FutureTask.java:123)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      at java.util.concurrent.FutureTask.run(FutureTask.java:123)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: java.io.IOException: error in opening zip file
      at org.springframework.ide.eclipse.core.io.FileResource.getInputStream(FileResource.java:79)
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:336)
      ... 12 more

        Activity

        cdupuis Christian Dupuis added a comment -

        Is there any import statement in the UniversalUserMaintenanceDocument.xml? I wonder why the UniversalUserMaintenanceDocument.xml file is referenced with the JAR syntax.


          People

          • Assignee:
            cdupuis Christian Dupuis
            Reporter:
            lindholm George Lindholm
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: