Spring Integration
  1. Spring Integration
  2. INT-2420

spring-integration-mongodb version on Import-Package

    Details

      Description

      spring-integration-mongodb, in its manifest file: Import-Package: com.mongodb;version="[2.4.0, 2.5.0]"

      This version range is too restrictive. The spring-data-mongodb project imports at version 0.0.0 (no version specified). This is probably because the mongo-java-driver-2.7.1.jar file exports com.mongodb at version 0.0.0 (no version specified). In fact it has the following:

      Export-Package: com.mongodb, com.mongodb.io, com.mongodb.util, com.mon
      godb.gridfs, org.bson, org.bson.util, org.bson.types, org.bson.io

      If you intend to use the standard mongo distribution jar, then spring-integration-mongodb must also import com.mongodb without a version specified.

        Activity

        Hide
        Mark Fisher added a comment -

        This should be a trivial change.

        Show
        Mark Fisher added a comment - This should be a trivial change.
        Show
        Oleg Zhurakousky added a comment - PR is https://github.com/SpringSource/spring-integration/pull/382

          People

          • Assignee:
            Oleg Zhurakousky
            Reporter:
            Don Laidlaw
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: