Spring Integration
  1. Spring Integration
  2. INT-2718

<chain> config is failed when nested <gateway>s have a 'request-channel' attribute

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Complete
    • Affects Version/s: 2.2 M4
    • Fix Version/s: 2.2 RC1
    • Component/s: Core
    • Labels:

      Activity

      Artem Bilan added a comment -

      The investigation shows, that it should be fixed inside AbstractConsumerEndpointParser#parseInternal around the invocation of method this.parseHandler(element, parserContext);.

      But there is some other side effect: parsing for 'request-handler-advice-chain' is made a bit below. So, if we place adviced component inside the <chain> it won't work, because our chained handler isn't adviced.
      For reproducing, config from simpleWebServiceOutboundGatewayParserTests.xml:

      <si:chain input-channel="gatewayWithAdviceInsideTheChain">
          <ws:outbound-gateway destination-provider="destinationProvider">
      	<ws:request-handler-advice-chain>
              	<bean class="org.springframework.integration.ws.config.WebServiceOutboundGatewayParserTests$FooAdvice"/>
      	</ws:request-handler-advice-chain>
          </ws:outbound-gateway>
      </si:chain>
      

      The issue is addresed as for AbstractConsumerEndpointParser, and for AbstractOutboundChannelAdapterParser.

      Well, I think, I'll fix it during this JIRA too, and soon.


        People

        • Assignee:
          Artem Bilan
          Reporter:
          Artem Bilan
        • Votes:
          0 Vote for this issue
          Watchers:
          1 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Time Tracking

            Estimated:
            Original Estimate - 1d
            1d
            Remaining:
            Remaining Estimate - 0d
            0d
            Logged:
            Time Spent - 1d
            1d