Uploaded image for project: 'Spring Integration'
  1. Spring Integration
  2. INT-2850

Even after using URL-expression instead of url in outboundGateway - my url picked from payload has %22 at the start and end

    Details

    • Type: Support
    • Status: Resolved
    • Priority: Minor
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Adapters
    • Labels:
      None

      Description

      Even after using Url-expression instead of url in outboundGateway - my url picked from payload has %22 at the start and end and gives the error

      Caused by: java.lang.IllegalStateException: Could not create URI object: Illegal character in scheme name at index 0: %22http://some.host/someService?someParam=someValue%22

      [Payload=http://some.host/someService?someParam=someValue]

      Exception Details
      org.springframework.integration.MessageHandlingException: HTTP request execution failed for URI ["http://some.host/someService?someParam=someValue]

        Activity

        mark.fisher Mark Fisher added a comment -

        It looks like your payload actually begins with a double-quote, and %22 is the escape character for that within the URL. Please confirm so that we can close this as INVALID.

        abilan Artem Bilan added a comment -

        Fixed as "Ivalid" with editting of sensitive data


          People

          • Assignee:
            mark.fisher Mark Fisher
            Reporter:
            dheerja.arora@accenture.com dheerja arora
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: