Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Complete
    • Affects Version/s: 2.2. GA
    • Fix Version/s: 3.0 M1, 2.2.1
    • Component/s: Core
    • Labels:

      Description

      When the ExpressionEvaluatingRequestHandlerAdvice detects an exception in the handler call, it is wrapped in a ThrowableHolderException. This is an internal device in the AbstractRequestHandlerAdvice and should not be exposed to users. The cause should be unwrapped before sending the ErrorMessage to the failureChannel.

        Activity


          People

          • Assignee:
            grussell Gary Russell
            Reporter:
            grussell Gary Russell
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: