Spring Integration
  1. Spring Integration
  2. INT-3049

DelayedMessageWrapper should be public in order to access the wrapped message from infrastructure code

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Complete
    • Affects Version/s: 2.2.1
    • Fix Version/s: 2.2.5, 3.0 M3
    • Component/s: Core
    • Labels:

      Description

      When using a delay the DelayMessageHandler wraps the message info a static private DelayedMessageWrapper instance, which contains the orignal message.

      There is no ability to access the original message in a regular way, except to use refelction tricks which is ugly.

      So DelayedMessageWrapper should be public.

        Issue Links

          Activity

          Artem Bilan added a comment -

          Thanks, Stefan!

          But it is 'Improvement': Framework doesn't provide any inconsistent behavior for current state.

          Stefan Rinke added a comment -

          thx, of cause. it's not a bug, i will be an improvment.

          Artem Bilan added a comment -

          This issue is very simple: will be addressed within INT-2243.

          Artem Bilan added a comment -
          Gary Russell added a comment -

          Merged


            People

            • Assignee:
              Artem Bilan
              Reporter:
              Stefan Rinke
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: