Uploaded image for project: 'Spring Integration'
  1. Spring Integration
  2. INT-3218

Don't Use CollectionUtils Where a Generic Type is Required

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Complete
    • Affects Version/s: None
    • Fix Version/s: 3.0 RC1
    • Component/s: None
    • Labels:
      None

      Description

      Spring Framework 4.0 added a generic type to CollectionUtils.arrayAsList(). There are 4 places in Spring Integration that require generic types when compiling against Spring 4.

      Rework those uses so that SI can be compiled against Spring 3 or 4.

        Attachments

          Activity

            People

            Assignee:
            grussell Gary Russell
            Reporter:
            grussell Gary Russell
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: