Spring Mobile
  1. Spring Mobile
  2. MOBILE-70

Absolute URLs are not handled correctly when redirecting

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0.M2
    • Fix Version/s: 1.1.0.RC1
    • Component/s: device
    • Labels:
      None

      Description

      The LiteDeviceDelegatingViewResolver does not correctly handle absolute URLs when redirecting.

      For example, the following URL,

      redirect:http://www.google.com/

      redirects to

      www.website.com/context/mobile/http://www.google.com/

        Activity

        Roy Clarkson added a comment -

        LiteDeviceDelegatingViewResolver shouldn't be adjusting view names when redirecting or forwarding, since the view resolver is handling that itself when it receives the request. Given that, I don't think having a configuration option is valuable. AbstractDeviceDelegatingViewResolver should probably just return the view name if it detects a redirect or forward.

        Roy Clarkson added a comment -
        MOBILE-70 Update to not adjust view name for redirect: and forward:
            
        AbstractDeviceDelegatingViewResolver was adjusting the view name
        based on the determined device type, which meant that redirects and
        forwards were going to potentially invalid URLs.
        
        Roy Clarkson added a comment -

        Petar Tahchiev and Scott Rossillo, if you have a minute, it would be helpful if you can confirm that the latest build snapshot resolves this issue for you. If so, we can get a release out with the fix. Thanks!

        Petar Tahchiev added a comment -

        I have tested with 1.1.0.BUILD-20130722.220855-53 and it works.

        Scott Rossillo added a comment -

        Confirmed your fix is working as well.


          People

          • Assignee:
            Roy Clarkson
            Reporter:
            Roy Clarkson
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: