After watching Bob's confusion figuring out RequestFactory, he's suggested some name changes. I'd like to get these into M3, but only after RayC and Amit's big changes land:
*Record -> *Proxy
@DataTransferObject -> @ProxyFor
Request selector -> Request builder
The last is the informal name for the objects that hang right off the RequestFactory, and mostly shows up in generated java doc and the source for RequestFactoryGenerator. E.g. in requests.employee().findAllEmployees(), the employee() all returns what should be called a request builder.