Uploaded image for project: 'Spring Roo'
  1. Spring Roo
  2. ROO-1430

Creation broken if the entity id is of type String.

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.1.0.M3
    • Fix Version/s: 1.1.0.RC1
    • Component/s: GWT
    • Labels:
      None

      Description

      Steps to reproduce:
      1. Change the type of the id field of SimpleFoo from Long to String.
      2. See tests fail, including testDummyCreate(..)

      The root cause of the testDummyCreate(...) failure is that the datastoreId in the sideEffects field is different from the datastoreId returned in the results field. Need to track down other failing tests as well.

      Rodrigo: since you were working on 1427, which is now obsolete, assigning it to you. Ray or I will check back with you tomorrow.

        Activity

        rjrjr@google.com Ray Ryan added a comment -

        Amit is working on this, and knows the terrain better


          People

          • Assignee:
            amitmanjhi@google.com Amit Manjhi
            Reporter:
            amitmanjhi@google.com Amit Manjhi
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: