Uploaded image for project: 'Spring Roo'
  1. Spring Roo
  2. ROO-1479

DBRE on a DB2400 datasource throwing IllegalArgumentException JDBC driver not available for 'com.ibm.as400.access.AS400JDBCDriver'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Complete
    • Affects Version/s: 1.1.0.M3
    • Fix Version/s: 1.1.0.RC1
    • Component/s: PERSISTENCE
    • Labels:
      None
    • Environment:
      MacBook Pro, OSX Snow Leopard (10.6.4), Eclipse with STS plugins

      Description

      Attempting to DBRE on a DB2400 datasource fails with java.lang.IllegalArgumentException: JDBC driver not available for 'com.ibm.as400.access.AS400JDBCDriver'.

      Have attempted to build Roo M4 from Git and copy the org.springframework.roo.wrapping.jtopen-6.7.0.0001.jar dependency into the M3 bundle directory. Have also tried DBRE right from M4, but both give the same result.

        Attachments

          Activity

            People

            Assignee:
            stewarta Alan Stewart
            Reporter:
            pgrimard Patrick Grimard
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: