Uploaded image for project: 'Spring Roo'
  1. Spring Roo
  2. ROO-1592

ROO finders and sorting (filtering)

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: DYNAMIC FINDERS
    • Labels:
      None

      Description

      It would be nice to have first level sorting ability with ROO finders,

      A generic sorting and filtering capability will go long way.

      So findSensorDatasBySensorAndSentTimeBetween can become findSensorDatasBySensorAndSentTimeBetweenXandYAndSorted
      or findSensorDatasBySensorAndSentTimeBetweenXandYAndSortedAndFilteredByTimesListZ

      The names can become ugly so some sort of aliasing could be nice as well.

        Issue Links

          Activity

          shahzada.hatim Shahzada Hatim added a comment -

          please rename the issue to finder filters, as other things are covered in previous issues.

          hwalker Harald Walker added a comment -

          Grouped with or duplicate of ROO-241


            People

            • Assignee:
              aswan Andrew Swan
              Reporter:
              shahzada.hatim Shahzada Hatim
            • Votes:
              4 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: