Spring Roo
  1. Spring Roo
  2. ROO-1780

touble with generated finder on object class

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Complete
    • Affects Version/s: 1.1.0.RELEASE
    • Fix Version/s: 1.1.1.RELEASE
    • Component/s: DYNAMIC FINDERS
    • Labels:
      None
    • Environment:
      linux ubuntu 10.10 and windows XP

      Description

      Generated finder cause an exception if i try to generate a finder on a non-String field.

      -Exception Message
      java.lang.String cannot be cast to org.zaza.B
      -Exception Stack Trace
      org.zaza.A_Roo_Finder.findASByBb_aroundBody0(A_Roo_Finder.aj:24)
      org.zaza.A_Roo_Finder.ajc$interMethod$org_zaza_A_Roo_Finder$org_zaza_A$findASByBb(A_Roo_Finder.aj:1)
      org.zaza.A.findASByBb(A.java:1)
      org.zaza.A_Roo_Finder.ajc$interMethodDispatch1$org_zaza_A_Roo_Finder$org_zaza_A$findASByBb(A_Roo_Finder.aj)
      ...

      I Feel strange that was working fine with the M3 Release

      1. log.roo
        0.9 kB
        eric molle
      1. bug.GIF
        28 kB

        Issue Links

          Activity

          eric molle added a comment -

          I forgot ! this issue was on the 1.1.0 Release release !!

          eric molle added a comment -

          At least any workarround for this issue ?

          Stefan Schmidt added a comment -

          This issue has been reported in SPR-7766 and seems to be a regression between Spring 3.0.4 and Spring 3.0.5. So downgrading your Spring version in the Roo application should resolve this problem.

          Stefan Schmidt added a comment -

          Eric, I'll go ahead and close this issue since Roo is doing the correct thing here but you are seeing a regression in Spring Framework. I expect this to be fixed for Spring 3.0.6. Since there is nothing we can do on the Roo side (apart from upgrading to the fixed Spring release) I will go ahead and close this issue. You should watch the Spring framework ticket.

          eric molle added a comment -

          ok great/thanks !

          eric molle added a comment -

          ps: i can confirm that changing from 3.0.4 to 3.0.5 in the pom.xml reproduce this bug.

          Rossen Stoyanchev added a comment -

          This has been scheduled to be fixed in Spring 3.0.6 (SPR-7781).


            People

            • Assignee:
              Stefan Schmidt
              Reporter:
              eric molle
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: