Spring Roo
  1. Spring Roo
  2. ROO-2171

Change version of AspectJ used in Roo projects to 1.6.11.M2

    Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Complete
    • Affects Version/s: 1.1.1.RELEASE
    • Fix Version/s: 1.1.2.RELEASE
    • Component/s: @ CORE
    • Labels:
      None

      Activity

      Hide
      James Tyrrell added a comment -

      Change made in commit 6fd10ea4ab2c4ffc61e4cb06e9289ad36baf0f88

      Show
      James Tyrrell added a comment - Change made in commit 6fd10ea4ab2c4ffc61e4cb06e9289ad36baf0f88
      Hide
      Andrew Swan added a comment -

      Can people still use a GA release of AspectJ? Or does the code generated by Roo 1.1.2 require AspectJ 1.6.11.M2?

      Show
      Andrew Swan added a comment - Can people still use a GA release of AspectJ? Or does the code generated by Roo 1.1.2 require AspectJ 1.6.11.M2?
      Hide
      James Tyrrell added a comment -

      Hey Andrew, it depends on what kind of database you are using in your project. The GAE support depends on a milestone release of AspectJ, 1.6.11M1+ to be precise, as it adds the ability to remove annotations from fields. Other than that using the latest GA version of AspectJ shouldn't be a problem, though I haven't tested it.

      Show
      James Tyrrell added a comment - Hey Andrew, it depends on what kind of database you are using in your project. The GAE support depends on a milestone release of AspectJ, 1.6.11M1+ to be precise, as it adds the ability to remove annotations from fields. Other than that using the latest GA version of AspectJ shouldn't be a problem, though I haven't tested it.

        People

        • Assignee:
          James Tyrrell
          Reporter:
          James Tyrrell
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: