Spring Roo
  1. Spring Roo
  2. ROO-2252

ROO generate GWT code that is GAE dependent even if not building for GAE

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Complete
    • Affects Version/s: 1.1.2.RELEASE
    • Fix Version/s: 1.1.3.RELEASE
    • Component/s: GWT
    • Labels:
      None
    • Environment:
      Windows/ STS 2,5,2

      Description

      After having setup the presistency and database, i created some basic entity

      Then I executed "gwt setup".

      After quite some time the scaffold project was created.
      It created a ~.server.gae package that failed to compile.

      This package contains the classes:
      GaeAuthFilter.java, UserSServiceLocator.java and UserServiceWrapper.java

      This package does not compile because the gae references could not be resolved:

      import com.google.appengine.api.users.UserService;
      import com.google.appengine.api.users.UserServiceFactory;

      So it seems that:
      1) gae classes are being created.
      2) gae classes cannot be compiled dependencies are not set.

      I can although execute the application (from console: mvn gwt:run)
      which runs as expected.

        Issue Links

          Activity

          James Tyrrell added a comment -

          Hey Joseph, can you please grab the latest snapshot of Roo here and let me know if the problem still persists.

          James Tyrrell added a comment -

          Removed final GAE dependency from a standard non-GAE GWT project in commit ec2ffea2ea724dfe8b0e4139be236e6ddc2108dd

          James Tyrrell added a comment -

          Fixed issue where the pom.xml wouldn't be correctly updated upon switching to and from GAE in commit 345f3698ecae13a177588948c1db896103a9ab2e

          James Tyrrell added a comment -

          I am not able to replicate this issue using the current master version of Roo (the changes of which will be used in the next Roo snapshot). GAE specific code is only added to the project when "persistence setup --provider DATANUCLEUS --database GOOGLE_APP_ENGINE" is run or if the "maven-gae-plugin" has been manually added to the pom.xml file.

          Attila Balogh added a comment -

          Using spring-roo-1.1.3.BUILD-SNAPSHOT_20110324.080051-52b13bf I still am experiencing this issue, have to delete gae package manually to have it working.

          log.roo:

          // Spring Roo 1.1.3.BUILD-SNAPSHOT [rev bef84b9] log opened at 2011-03-25 11:49:39
          project --topLevelPackage foo.bar
          persistence setup --provider HIBERNATE --database MYSQL
          osgi obr url add --url http://spring-roo-repository.springsource.org/repository.xml
          osgi obr start --bundleSymbolicName org.springframework.roo.wrapping.mysql-connector-java
          osgi obr url remove --url http://spring-roo-repository.springsource.org/repository.xml
          addon install id --searchResultId 01
          database introspect --schema no-schema-required
          database reverse engineer --schema no-schema-required
          gwt setup
          perform package
          exit
          // Spring Roo 1.1.3.BUILD-SNAPSHOT [rev bef84b9] log closed at 2011-03-25 11:58:48

          Yuriy Ribitskiy added a comment -

          The bug is still present.

          I've just tried nightly build spring-roo-1.1.3.BUILD-SNAPSHOT_20110404.105742-cff4477.zip.

          I see the gae directory under server and shared.

          Nick Evans added a comment -

          I concur, the bug is still present in spring-roo-1.1.3:

          project --topLevelPackage org.foo.bar
          persistence setup --provider HIBERNATE --database POSTGRES
          gwt setup

          I have to delete the following GAE packages for each rerun of my roo script, in order for it to build in STS:

          org.foo.bar.client.scaffold.gae
          org.foo.bar.server.gae
          org.foo.bar.shared.gae

          Jeff Cherng added a comment -

          The issue is not resolved. Clean installation of Spring STS 2.6.0 SR1 (with Spring Roo 1.1.3) can also reproduce this issue (expenses.roo was used). Please re-visit this issue.

          dkp added a comment -

          I also have the exact same issue using:

          Spring STS 2.6.0.201103160035-RELEASE
          Spring ROO 1.1.3
          Eclipse Helios SR2

          I have m2eclipse installed as wel, which may have a negative impact. Probably not relevant, but running on Windows 7 64bit


            People

            • Assignee:
              James Tyrrell
              Reporter:
              Joseph
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: