Spring Roo
  1. Spring Roo
  2. ROO-2275

WebFlow Addon: Configure ConversionServiceExposingInterceptor on FlowHandlerMapping by default

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Complete
    • Affects Version/s: 1.1.2.RELEASE
    • Fix Version/s: 1.1.3.RELEASE
    • Component/s: WEB MVC
    • Labels:
      None

      Description

      See forum thread for complete details. Basically, certain Spring JSP tags (spring:eval in particular) expect the ConversionService instance to be exposed on the pageContext/request, otherwise they create a new default instance. This instance does not include custom converters for Roo-generated entities - leading to ConverterNotFoundExceptions.

      The problem is only evident when accessing views with the spring:eval tag using WebFlow, since the <mvc:annotation-driven> tag automatically registers the appropriate ConversionServiceExposingInterceptor for MVC @Controller mappings. There is no such automatic registration for the FlowHandlerMapping.

      I've attached a fragment of the changes to Roo-generated webflow-config.xml that accomplish this. Note this fragment includes two additional edits: the commenting out of the AnnotationMethodHandlerAdapter (also automatically registered by mvc:annotation-driven) and SimpleControllerHandlerAdapter (unnecessary for Roo since Roo uses @Controller instances by default). These last 2 edits perhaps need their own issue.

        Issue Links

          Activity

          Stefan Schmidt added a comment -

          Thanks for the effort of researching this! I committed the proposed changes with rev 0096db34be74762d0cfd90872f35e12d43344661.


            People

            • Assignee:
              Stefan Schmidt
              Reporter:
              Rory Douglas
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: