Uploaded image for project: 'Spring Roo'
  1. Spring Roo
  2. ROO-2322

Invalid dependency between upstream ... and downstream ...

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Complete
    • Affects Version/s: 1.1.2.RELEASE, 1.1.5.RELEASE
    • Fix Version/s: 1.2.0.RC1
    • Component/s: TESTING
    • Labels:
      None
    • Environment:
      Windows 7 professional.
      STS 2.6.0.RELEASE.

      Description

      When RooShell is started on a project in STS, the following message is shown:

      Invalid dependency between upstream 'MID:org.springframework.roo.addon.dod.DataOnDemandMetadata#SRC_TEST_JAVA?br.com.brpex.paavo.dominio.PedidoDataOnDemand' and downstream 'MID:org.springframework.roo.addon.dod.DataOnDemandMetadata#SRC_TEST_JAVA?br.com.brpex.paavo.dominio.AndamentoPedidoDataOnDemand'

      Moreover, Roo not updated the files .j when i change my entities adding a new field, for example. Is that a problem is related to the first one?

      Thanks.

        Attachments

          Activity

            People

            Assignee:
            aswan Andrew Swan
            Reporter:
            brunopex Bruno J. S. Peixoto
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: