Spring Roo
  1. Spring Roo
  2. ROO-2382

Error: Member holding type details required

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.1.3.RELEASE
    • Fix Version/s: None
    • Component/s: PERSISTENCE
    • Labels:
    • Environment:
      Ubuntu 9.10 64-bit, sts-2.6.0.SR1, Oracle 11g 11.1.0.6.0 64-bit

      Description

      I'm using Roo 1.1.3.RELEASE [rev 4404ffb] on Ubuntu with Java 1.6.0_21_x64 connecting to an Oracle DB.

      Trying to run database reverse engineer --schema ... --testAutomatically yields the following output:

      roo> database reverse engineer --schema <schema> --testAutomatically
      Created SRC_MAIN_RESOURCES/dbre.xml
      Undo manage SRC_MAIN_RESOURCES/META-INF/persistence.xml
      Undo manage ROOT/pom.xml
      Undo create SRC_MAIN_RESOURCES/dbre.xml
      Member holding type details required
      roo> Created SRC_MAIN_JAVA/ar/GomezFact_Roo_Entity.aj
      Created SRC_MAIN_JAVA/ar/GomezFactPK_Roo_Identifier.aj
      Deleted SRC_MAIN_JAVA/ar/GomezFact_Roo_Entity.aj
      Deleted SRC_MAIN_JAVA/ar/GomezFactPK_Roo_Identifier.aj

      Running the same command without the "--testAutomatically" parameter yields:

      roo> database reverse engineer --schema NEW_ODS
      Created SRC_MAIN_RESOURCES/dbre.xml
      Created SRC_MAIN_JAVA/ar/GomezFactPK.java
      Created SRC_MAIN_JAVA/ar/GomezFact.java
      Created SRC_MAIN_JAVA/ar/GomezIspDim.java
      Created SRC_MAIN_JAVA/ar/GomezVariableDim.java
      Undo create SRC_MAIN_JAVA/ar/GomezVariableDim.java
      Undo create SRC_MAIN_JAVA/ar/GomezIspDim.java
      Undo create SRC_MAIN_JAVA/ar/GomezFact.java
      Undo create SRC_MAIN_JAVA/ar/GomezFactPK.java
      Undo manage SRC_MAIN_RESOURCES/META-INF/persistence.xml
      Undo manage ROOT/pom.xml
      Undo create SRC_MAIN_RESOURCES/dbre.xml
      Type for table 'GOMEZ_VARIABLE_DIM' could not be found but was referenced by table 'GOMEZ_FACT'
      roo> Created SRC_MAIN_JAVA/ar/GomezFact_Roo_Entity.aj
      Created SRC_MAIN_JAVA/ar/GomezFactPK_Roo_Identifier.aj
      Deleted SRC_MAIN_JAVA/ar/GomezFact_Roo_Entity.aj
      Deleted SRC_MAIN_JAVA/ar/GomezFactPK_Roo_Identifier.aj

      DDL for creating the three tables and sequences in the schema is attached.

      1. gomez_new.sql
        1 kB
        Ben Zimmerman
      2. script.log
        7 kB
        Alan Stewart

        Activity

        Alan Stewart added a comment -

        I can't reproduce the issue with either 1.1.3.RELEASE or the latest 1.1.4 snapshot code. The entities get created correctly.

        Alan Stewart added a comment -

        See the attached script.log output. The project was created from scratch

        Alan Stewart added a comment -

        I used 64-bit Ubuntu 10.10 with Oracle 1.6.0_24 JDK. This can be re-opened if you can show this issue repeatedly occurs on another environment

        Massimo Franzoni added a comment -

        I got the same error (in 1.1.4) deleting by hand the source directory and the dbre.xml in my attempts to reverse gen a schema.
        Exiting e reentering roo solved my problem.

        Jose Mendez added a comment -

        I also got the same error. I work with postgresql and spring roo 1.4

        Jose Mendez added a comment -

        I forgot the log:
        roo> database reverse engineer --schema user --package ~.domain.user
        Updated SRC_MAIN_RESOURCES\dbre.xml
        Updated ROOT\pom.xml
        Updated SRC_MAIN_RESOURCES\META-INF\persistence.xml
        Undo manage SRC_MAIN_RESOURCES\META-INF\persistence.xml
        Undo manage ROOT\pom.xml
        Undo manage SRC_MAIN_RESOURCES\dbre.xml
        Member holding type details required
        roo> NullPointerException at org.springframework.roo.addon.dbre.DbreDatabaseListenerImpl.reverseEngineer(DbreDatabaseListenerImpl.java:116)


          People

          • Assignee:
            Alan Stewart
            Reporter:
            Ben Zimmerman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: