Spring Roo
  1. Spring Roo
  2. ROO-2603

Sets and Integers not appearing in some views.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.5.RELEASE
    • Fix Version/s: 1.2.0.M1
    • Component/s: WEB MVC
    • Labels:
      None
    • Environment:
      Mac OS 10.6.8

      Description

      This is a follow-up to the forum thread:
      http://forum.springsource.org/showthread.php?112415-Sets-not-appearing-in-quot-show-quot-views.&p=373337#post373337

      The following examples refer to the attached domain objects and fields.

      Regarding the fact that some Integers are not displayed: For example a Practice's
      formalityLevel,
      qualityLevel,
      speedLevel,
      valueLevel,
      perceptionLevel and
      outcomeProductionDirectness
      are not displayed on the Practices' list.

      Regarding the fact that some Sets are not displayed: For example a Risk's Set<OutcomeSufficiency> is correctly displayed on the Risk's "list" view, but not on its "show" view.

        Activity

        Stefan Schmidt added a comment -

        Carlos, I just took a look at your project and the reason why not all fields in your domain objects are displayed in the list view is that there is limited screen space for table columns. For this reason Roo will by default present the first 7 fields in the list view and skip the ones after that. Remember, the list view is just meant as a short summary table rather than a presentation of the full dataset. To see all fields you can enter the show view.

        You can, however manually add more fields to the list view if you wish (ie Practice with added perceptionLevel):

        <table:table data="${practices}" id="l_rop_manager_Practice" path="/practices" z="KEDyQ60c86WldOpAp6NN04rb7vU=">
          <table:column id="c_rop_manager_Practice_name" property="name" z="TfgZweYlxo3WeiNcXFbRC88dKEI="/>
          <table:column id="c_rop_manager_Practice_briefDescription" property="briefDescription" z="3NLCU0LS0VczjUzm/H5esjM7oPs="/>
          <table:column id="c_rop_manager_Practice_purpose" property="purpose" z="q0jVaVTx8zFg5TSD/WYZ69Oqcas="/>
          <table:column id="c_rop_manager_Practice_mainDescription" property="mainDescription" z="8oQqQD2d905qIcjptayk4Vpj+4k="/>
          <table:column id="c_rop_manager_Practice_requiresCollaboration" property="requiresCollaboration" z="Ci8+tx5TXra2sSbd8r73DjGgbck="/>
          <table:column id="c_rop_manager_Practice_formalityLevel" property="formalityLevel" z="479fkJicpuMZZNXIuEcn8ZcZEAM="/>
          <table:column id="c_rop_manager_Practice_perceptionLevel" property="perceptionLevel" z="user-managed"/>
        </table:table>
        

        Roo will not remove this manually added code from your jspx. Please let me know if this answers your question.

        Carlos Sanchez added a comment -

        Thanks Stefan.

        You did answer the first part of my question, i.e. "the fact that some Integers are not displayed".

        However there was a second part of my question, i.e. "the fact that some Sets are not displayed".

        And that's in fact the most critical question

        Stefan Schmidt added a comment -

        Carlos, I must have overlooked the second part of your question. Indeed, this was inconsistent and with commit d98a64464cf93d072d85d68ec4abffb023f0d0dd list views do not contain columns for @OneToMany relationships any more.

        Carlos Sanchez added a comment -

        Stefan, the problem is in fact:

        • not that Sets are displayed on the "list" views (although that is indeed not necessary), but
        • that Sets are not displayed on the "show" views...
        Stefan Schmidt added a comment -

        Carlos, with a recent snapshot build you should be able to see that these sets are not presented in either list or show views any more. Please try out a recent build from here http://static.springsource.org/downloads/nightly/snapshot-download.php?project=ROO


          People

          • Assignee:
            Stefan Schmidt
            Reporter:
            Carlos Sanchez
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: