Spring Roo
  1. Spring Roo
  2. ROO-3072

Spring roo shell error for perform tests

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Works as Designed
    • Affects Version/s: 1.2.1.RELEASE
    • Fix Version/s: None
    • Component/s: @ ROO SHELL
    • Environment:
      win7 64bit,

      SpringSource Tool Suite
      Version: 2.8.1.RELEASE
      Build Id: 201111221000

      Description

      my configuration is win7 64bit using springsource-tool-suite-2.8.1.RELEASE-e3.7.1-win32-x86_64.
      I recently updated my roo version from spring-roo-1.1.5.RELEASE to spring-roo-1.2.1.RELEASE and followed following steps to update the verion in springsource-tool-suite: windows->preference->spring->roo support and then added the new roo instalation.
      as i was getting an error running the perform tests command in roo 1.1.5 which said "mvn.bat not found".

      now following error comes for "perform tests" command:
      CreateProcess error=2, The system cannot find the file specified

      please suggest any workarounds if possible.

        Activity

        Stephan Schaefer added a comment -

        Okay, I found the solution. The problem is, that the Roo shell tries to execute the maven binary but it can't do this when you don't have maven in your path. So I would suggest to add a configuration file to Spring Roo where you can define these kind of settings.

        Soltuion: Add the Maven binary (Directory) to your PATH. STS don't do this job for you.

        Alan Stewart added a comment -

        I will resolve this as works as designed, given that Roo does expect maven to be in the path.

        Stephan Schaefer added a comment -

        Sounds okay for me.

        Xinghe added a comment -

        Thanks Stephan Schaefer answers this question, I also met such a problem. Has now been solved.

        Logan M added a comment -

        I suggest Roo shell to be more verbose by first checking that "mvn" command in available on PATH.


          People

          • Assignee:
            Alan Stewart
            Reporter:
            Mohit Rodey
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: