Spring Roo
  1. Spring Roo
  2. ROO-3074

Roo shell unresponsive after removing ~/.spring_roo_pgp.bpg

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.2.1.RELEASE
    • Fix Version/s: None
    • Component/s: @ ROO SHELL
    • Environment:
      VMWare VM: Ubuntu 11.10, JDK 1.6.0_30, STS 2.8.1.RELEASE, all 64-bit.

      Description

      Somehow, I got myself into the situation described at
      https://issuetracker.springsource.com/browse/STS-1931
      I think it had to do with the fact that I was using 1.2.1.RELEASE in my bash shell, but 1.1.5.RELEASE via STS.

      The workaround described in STS-1931 is to delete ~/.spring_roo_pgp.bpg and restart Roo. Unfortunately, with 1.2.1.RELEASE, the shell was still unresponsive, although the exception & stack trace where gone.

      After downgrading to 1.2.0.RELEASE and redoing the workaround, everything worked fine. Unless this is a red herring, this looks to be an issue with Roo 1.2.1.RELEASE.

      1. log.roo
        0.6 kB
        Alex Beardsley
      2. Roo Exception 1.3.0.-SNAPSHOT_20120514.080057-e763d2c.txt
        12 kB
        Alex Beardsley
      3. Roo Stack Trace.txt
        7 kB
        Alex Beardsley

        Issue Links

          Activity

          Alan Stewart added a comment -

          Are you behind a firewall?

          Isaac Johnson added a comment -

          Yes, I am.

          Alan Stewart added a comment -

          Please try in a location without a firewall

          Alan Stewart added a comment -

          Need to release 1.2.2 so this can be revisited later, but at present we cant reproduce it

          Isaac Johnson added a comment -

          I'm guessing it wasn't a problem with being behind a firewall, because roo had been working within the firewall prior to this problem.

          I was also able to get around this error by deleting ~/.spring_roo_pgp.bpg


            People

            • Assignee:
              Alan Stewart
              Reporter:
              Matthew T. Adams
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: