Uploaded image for project: 'Spring Roo'
  1. Spring Roo
  2. ROO-3235

Roo does not deploy onto Tomcat

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Works as Designed
    • Affects Version/s: 1.2.2.RELEASE
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:
      Tomcat 6 & 7

      Description

      When deploying to Tomcat, as opposed to Vmware server, Roo apps gives

      tomcat v6.0 "Could not add one or more tag libraries." (You get a more detailed error in tomcat 7.0.)

      More details here http://forum.springsource.org/showthread.php?129084-Tag-lib-not-found-under-tomcat-6-0-but-is-found-under-VMWare-vFabric-server-why

      I found this solution
      http://spring-java-ee.blogspot.co.uk/2010/02/solving-tomcat-jsf-20-error.html

      which worked for me on Tomcat 7.0 but not Tomcat 6.0

      It says to use

      <dependency>
      <groupId>javax.el</groupId>
      <artifactId>el-api</artifactId>
      <version>2.2</version>
      <scope>provided</scope>
      </dependency>
      <dependency>
      <groupId>org.glassfish.web</groupId>
      <artifactId>el-impl</artifactId>
      <version>2.2</version>
      <scope>runtime</scope>
      </dependency>

      where Roo has

      <version>1.0</version>

        Attachments

          Activity

            People

            Assignee:
            stewarta Alan Stewart
            Reporter:
            greg.soulsby Gregory J Soulsby
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: