Spring Roo
  1. Spring Roo
  2. ROO-3258

STS 3.0.0.Release / GWT: missing Field in template files

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.2.2.RELEASE
    • Fix Version/s: None
    • Component/s: GWT
    • Labels:
      None
    • Environment:
      STS 3.0.0.RELEASE
      ROO 1.2.2.RELEASE

      Description

      If you run the expenses.roo example, the new implementation for *SetEditor is utilizing:
      [CODE]
      @UiField
      FlexTable table;
      [/CODE]
      but the field is never used in the corresponding ui.xml file. After running the sample expenses.roo example you get the following error for all three main entities:

      Field table has no corresponding field in template file for EmployeeSetEditor.ui.xml
      Field table has no corresponding field in template file for ExpenseSetEditor.ui.xml
      Field table has no corresponding field in template file for ReportSetEditor.ui.xml

        Activity

        Alan Stewart added a comment -

        Please provide a patch to fix.

        Alan Stewart added a comment -

        Does running expenses using mvn gwt:run from the command work for? It does for me

        Alan Stewart added a comment -

        expenses.roo works for me. Not heard back so closing now.


          People

          • Assignee:
            Unassigned
            Reporter:
            Arash
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: