Spring Roo
  1. Spring Roo
  2. ROO-3369

Roo command works fine on 1.2.2.RELEASE but not on 1.2.3.RELEASE

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.2.3.RELEASE
    • Fix Version/s: None
    • Component/s: @ ROO SHELL
    • Labels:
      None
    • Environment:
      Linux Lubuntu

      Description

      Here is the script:

      project --topLevelPackage com.learnintouch.lms --packaging POM
      module create --moduleName data --topLevelPackage com.learnintouch.lms.data

      On Roo 1.2.3.RELEASE it will give an undo create whereas on 1.2.2.RELEASE it works fine.

        Activity

        Alan Stewart added a comment -

        I tried the commands with Roo 1.2.3 on Windows 7 and it works for me. I don't currently have access to a Ubuntu machine

        roo> project --topLevelPackage com.learnintouch.lms --packaging POM
        Created ROOT\pom.xml
        roo> module create --moduleName data --topLevelPackage com.learnintouch.lms.data
        
        Created ROOT\data
        Created ROOT\data\pom.xml
        Created data|SPRING_CONFIG_ROOT
        Created data|SPRING_CONFIG_ROOT\applicationContext.xml
        Updated ROOT\pom.xml [added module data]
        data roo>
        

        I tried this commands with HEAD Roo 1.2.4 SNAPSHOT on Ubuntu 12.10 and works for me too.

        Regards !


          People

          • Assignee:
            Alan Stewart
            Reporter:
            Stephane
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: