Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 2.0.0.M1
    • Fix Version/s: None
    • Component/s: @ CORE
    • Labels:
      None

      Description

      To replace the Apache Felix Maven SCR Plugin plus the Apache Felix Maven Bundle Plugin by the new bnd Maven Plugin will simplify the project layout in the way described by Neil Bartlett at Announcing the bnd Maven Plugin. The expected release date is sept 2015 (https://groups.google.com/forum/#!topic/bndtools-users/yYSh5h6xqzk).

      The main problem to solve is the Bnd and Bndtools are now built targeting Java 7. So they require Java 7 or later to run as said in https://github.com/bndtools/bndtools/wiki/Changes-in-3.0.0.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                eruiz Enrique Ruiz (DiSiD)
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: