Spring Roo
  1. Spring Roo
  2. ROO-376

Not able to create field on an existing entity

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.0.0.RC2
    • Fix Version/s: 1.0.0.RC4
    • Component/s: None
    • Labels:
      None
    • Environment:
      OS : Vista , Java 1.6 , MAven 2.2.1

      Description

      Created an entity named Employee added some fields
      Created another entity named EmpDetails and added some fields
      Tried adding one more field to Employee but failed
      Tried adding field to EmpDetails and succeeded

      Not sure if I am using the rite versions (Java 1.6?)

      Also not sure how to use backup
      roo> backup
      The filename, directory name, or volume label syntax is incorrect
      roo> hint backup
      Cannot find topic 'backup'

        Issue Links

          Activity

          Ben Alex added a comment -

          The "backup" error is likely due to ROO-277. Please try it with Roo 1.0.0.RC3 as I think you'll find it will be fine.

          Re the error adding a field, what is the error message that Roo reports? Can you please type "development mode" and hit enter, and paste in the full output when the error is display.

          Ben Alex added a comment -

          Message posted to forum thread: "I am now on RC3. soon will try the same sequence which led to an error in RC2 and let you know."

          Ben Alex added a comment -

          Hi Rohit, is this still a problem for you? If not I would like to close this issue as a duplicate of ROO-277. Would you please let me know.

          Ben Alex added a comment -

          Closed as a duplicate, as the 'backup' command output is identical to ROO-277. If the other problem described remains in Roo 1.0.0.RC3, would you please log a new ticket and we'll be pleased to take a look.


            People

            • Assignee:
              Ben Alex
              Reporter:
              Rohit Pant
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: