Spring Roo
  1. Spring Roo
  2. ROO-501

CLONE -Persistence setup options not taking effect

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0.0.RC3
    • Fix Version/s: 1.0.1.RELEASE
    • Component/s: PERSISTENCE
    • Labels:
      None
    • Environment:

      SpringSource Tool Suite

      Version: 2.2.1.200910210131-RELEASE
      Roo 1.0.0.RC3 [rev 401]

      Description

      seems these options do not have the correct effect.

      When I do:
      persistence setup --provider HIBERNATE --database MYSQL --databaseName roofeed --userName root
      Managed SRC_MAIN_RESOURCES/META-INF/persistence.xml
      Managed SRC_MAIN_RESOURCES/META-INF/spring/database.properties
      please enter your database details in src/main/resources/database.properties
      Managed SRC_MAIN_RESOURCES/META-INF/spring/applicationContext.xml

      I end up with this database.properties:
      #Updated at Thu Dec 10 17:16:33 CET 2009
      #Thu Dec 10 17:16:33 CET 2009
      database.password=
      database.url=jdbc\:mysql\://localhost\:3306
      database.username=
      database.driverClassName=com.mysql.jdbc.Driver

        Issue Links

          Activity

          ezekfred added a comment -

          everything worked fine with rc4 but work no more with 1.0.0 GA.
          We have to modify database.properties by hand like this:

          from
          database.url=jdbc\\\:mysql\\\:

          to
          database.url=jdbc\:mysql\://localhost\:3306/mydb

          Stefan Schmidt added a comment -

          This is caused by a bug in Roo shell. I'll close this issue in favor of ROO-517.

          Stefan Schmidt added a comment -

          Should have been marked 'duplicate' not 'fixed'


            People

            • Assignee:
              Stefan Schmidt
              Reporter:
              ezekfred
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: