Spring Roo
  1. Spring Roo
  2. ROO-502

[external] Bug in Spring namespace handler causes Roo wedding RSVP app to show 1 error and 71 warnings in STS

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 1.0.0.RELEASE
    • Fix Version/s: 1.0.2.RELEASE
    • Component/s: None
    • Labels:
      None
    • Environment:
      Mac OS X 10.6.2 and STS 2.3.0

      Description

      Logging here as a bug as recommended by Ben Alex. As on forum the roo wedding rsvp app results in 1 error and 71 warnings when imported into STS 2.3.0. I will upload the error and warnings descriptions as a separate file. Thanks.

        Issue Links

          Activity

          Narada Sage added a comment -

          Log of all errors and warnings in the roo wedding rsvp application.

          skyrie wall added a comment -

          Hi... i was having the same issue when importing the pizzashop sample int STS 2.3.0 in ubuntu.

          Ben Alex added a comment -

          Stefan, would you mind having a look at this to see if you can reproduce? I cannot reproduce it with roo-dev rev 583 script vote.roo against STS 2.3.0.RELEASE 200912171331 GTK 32 bit on Ubuntu 9.10 with Sun JDK 1.6.0_16 or 1.6.0_18.

          Stefan Schmidt added a comment -

          Yes, this is a known problem. Ben you should see it in imported applications which have a web layer. There should be an error marker on webmvc-config.xml present.

          The error message you are seeing is caused by a small bug in a Spring Framework namespace handler which is used to validate the webmvc-config.xml file. See https://issuetracker.springsource.com/browse/STS-723 for details. This has been resolved and should be fixed with the release of Spring Framework 3.0.1 and STS 2.3.1. This bug does not affect the runtime of your application in any way, it is just a XML validation issue introduced by last minute changes in the new MVC namespace in Spring Framework.

          Roo is actually not doing anything wrong here so I will close the bug ticket as soon as Spring 3.0.1 and STS 2.3.1 are released.

          Stefan Schmidt added a comment -

          I am closing this ticket given that the fix for it will be included in the upcoming Spring framework 3.0.1 release. Roo will be updated to use SFW 3.0.1 once it is released.


            People

            • Assignee:
              Stefan Schmidt
              Reporter:
              Narada Sage
            • Votes:
              2 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: