Spring Security
  1. Spring Security
  2. SEC-1028

spring-security-2.0.4.xsd doesn't allow content inside <custom-authentication-provider>

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 2.0.4
    • Fix Version/s: 3.0.0 M1
    • Component/s: Namespace
    • Labels:
      None
    • Environment:
      Java 6u7, Kubuntu 8.04, Linux x86

      Description

      The XSD doesn't allow any content while documentation suggest that I should decorate my custom authenticationProvider beans with it.

      Is there something I misunderstand from the following or is this a bug?
      "Element used to decorate an AuthenticationProvider bean to add it to the internal
      AuthenticationManager maintained by the namespace."

        Activity

        Hide
        Luke Taylor added a comment -

        Please read the namespace chapter of the reference manual to find out how to use it

        http://static.springframework.org/spring-security/site/reference/html/ns-config.html#ns-access-manager

        Show
        Luke Taylor added a comment - Please read the namespace chapter of the reference manual to find out how to use it http://static.springframework.org/spring-security/site/reference/html/ns-config.html#ns-access-manager

          People

          • Assignee:
            Luke Taylor
            Reporter:
            Joonas Koivunen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: