Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.4
    • Fix Version/s: 3.0.0 M1
    • Component/s: ACLs, Core
    • Labels:
      None

      Description

      There is no longer much purpose in having a single base exception throughout the framework, given the diversity of uses. It would make more sense to have the base exceptions for the core areas of functionality (acls, access-failure, authentication-failure etc) extend NestedRuntimeException individually as the Spring Framework does.

        Activity

        luke Luke Taylor added a comment -

        I've introduced a new base class for Acl exceptions. ExceptionTranslationFilter now checks explicitly or AccessDeniedException and AuthenticationException (as it really should) and Jaas exceptions are translated to AuthenticationException instances.

        luke Luke Taylor added a comment -

        In retrospect, there's no need to use NestedRuntimeException anymore as basic Java classes now all provide access to the root cause.


          People

          • Assignee:
            luke Luke Taylor
            Reporter:
            luke Luke Taylor
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: