Spring Security
  1. Spring Security
  2. SEC-1397

NoSuchMethodError: org.springframework.beans.factory.xml.BeanDefinitionParserDelegate.getLocalName(Lorg/w3c/dom/Node;)Ljava/lang/String;

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Invalid
    • Affects Version/s: 3.0.1
    • Fix Version/s: 3.0.2
    • Component/s: None
    • Labels:
      None
    • Environment:
      Spring 3.0

      Description

      I'm unable to use Spring Security 3.0.1:

      Caused by: java.lang.NoSuchMethodError: org.springframework.beans.factory.xml.BeanDefinitionParserDelegate.getLocalName(Lorg/w3c/dom/Node;)Ljava/lang/String;
      at org.springframework.security.config.SecurityNamespaceHandler.parse(SecurityNamespaceHandler.java:45)
      at org.springframework.beans.factory.xml.BeanDefinitionParserDelegate.parseCustomElement(BeanDefinitionParserDelegate.java:1297)
      at org.springframework.beans.factory.xml.BeanDefinitionParserDelegate.parseCustomElement(BeanDefinitionParserDelegate.java:1287)
      at org.springframework.beans.factory.xml.DefaultBeanDefinitionDocumentReader.parseBeanDefinitions(DefaultBeanDefinitionDocumentReader.java:135)
      at org.springframework.beans.factory.xml.DefaultBeanDefinitionDocumentReader.registerBeanDefinitions(DefaultBeanDefinitionDocumentReader.java:92)
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.registerBeanDefinitions(XmlBeanDefinitionReader.java:507)
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:398)
      ... 37 more

        Activity

        Hide
        Dennis Kieselhorst added a comment -

        Please mark this issue as invalid. There was an old spring 2.5.6 jar on classpath.

        Show
        Dennis Kieselhorst added a comment - Please mark this issue as invalid. There was an old spring 2.5.6 jar on classpath.
        Hide
        Steppe jens added a comment -

        We have the same issue at the moment, can you explain how you solved this?

        We work with spring 2.5.6 and spring security 3.0.0 RELEASE

        Thank you

        Show
        Steppe jens added a comment - We have the same issue at the moment, can you explain how you solved this? We work with spring 2.5.6 and spring security 3.0.0 RELEASE Thank you
        Hide
        Dennis Kieselhorst added a comment -

        Spring 2.5.6 is not compatible with Spring Security 3. You must use Spring 3.

        Show
        Dennis Kieselhorst added a comment - Spring 2.5.6 is not compatible with Spring Security 3. You must use Spring 3.
        Hide
        pinot noir added a comment -

        Just a note for people having the same problem: you must use Spring 3 RELEASE, with Spring 3 M4 you will also have the problem.

        Show
        pinot noir added a comment - Just a note for people having the same problem: you must use Spring 3 RELEASE, with Spring 3 M4 you will also have the problem.
        Hide
        Nilesh Bharambe added a comment -

        I am getting the same error using Spring 3.0.2 and while deploying on Weblogic server 10.3.2.0 as well as 10.3.3.0 but when i deploy my application on weblogic server 10.3.1.0 its running fine.
        Is it bug??

        Show
        Nilesh Bharambe added a comment - I am getting the same error using Spring 3.0.2 and while deploying on Weblogic server 10.3.2.0 as well as 10.3.3.0 but when i deploy my application on weblogic server 10.3.1.0 its running fine. Is it bug??
        Hide
        hari added a comment -

        Hi I see the exact error Deploying t0 Oracle 11g weblogic 10.3.3 with spring 3.0, spring security 3.0 , letem know if you have a fix for this

        Show
        hari added a comment - Hi I see the exact error Deploying t0 Oracle 11g weblogic 10.3.3 with spring 3.0, spring security 3.0 , letem know if you have a fix for this
        Hide
        Connor Barry added a comment -

        I see the same error using Spring Security 3.0.5.RELEASE, WebLogic 10.2, with no instances of any earlier version of Spring on the classpath. Should be reopened?

        Show
        Connor Barry added a comment - I see the same error using Spring Security 3.0.5.RELEASE, WebLogic 10.2, with no instances of any earlier version of Spring on the classpath. Should be reopened?
        Hide
        Luke Taylor added a comment -

        The method exists in Spring 3.0. If you get this exception then you have an incompatible version of Spring, either in your app or inadvertently provided by the app server.

        Show
        Luke Taylor added a comment - The method exists in Spring 3.0 . If you get this exception then you have an incompatible version of Spring, either in your app or inadvertently provided by the app server.

          People

          • Assignee:
            Luke Taylor
            Reporter:
            Dennis Kieselhorst
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: