Uploaded image for project: 'Spring Security'
  1. Spring Security
  2. SEC-1600

Add version data and also initialization checks on Spring version in use to detect incompatibilities

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Complete
    • Affects Version/s: None
    • Fix Version/s: 3.0.4, 3.1.0.M2
    • Component/s: None
    • Labels:
      None

      Description

      Using the wrong versions or accidentally polluting the classpath with incompatible jars is one of the most common sources of user errors. Spring FW already has version information available which we can read. We should also do the same for Spring Security modules and check for inconsistencies.

        Activity

        Hide
        issuemaster Spring Issuemaster added a comment -
        Show
        issuemaster Spring Issuemaster added a comment - This issue has been migrated to https://github.com/spring-projects/spring-security/issues/1789

          People

          • Assignee:
            luke Luke Taylor
            Reporter:
            luke Luke Taylor
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development