Spring Security
  1. Spring Security
  2. SEC-1999

Package org.springframework.context.* is imported with wrong versionrange

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 3.1.1
    • Fix Version/s: 3.1.2
    • Component/s: ACLs
    • Labels:
      None
    • Environment:
      OSGi

      Description

      The package org.springframework.context.* is imported with the security versionrange instead of the springframework versionrange. This is a simple copy/paste typo in template.mf, line *17:

      org.springframework.context.*;version="${secRange}";resolution:=optional
      

      should be

      org.springframework.context.*;version="${springRange}";resolution:=optional
      

        Activity

        Hide
        Rob Winch added a comment -

        Thank you for your submission. This is fixed in master.

        Show
        Rob Winch added a comment - Thank you for your submission. This is fixed in master.

          People

          • Assignee:
            Rob Winch
            Reporter:
            Christian Brensing
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: