Spring Security
  1. Spring Security
  2. SEC-2149

Spring Security 3.2.0M1 and 3.1.3 release not compatible with spring framework 3.2.1 release with OSGi

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1.3, 3.2.0.M1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Attempting to upgrade spring framework to 3.2.1 and spring security to 3.2.0. The spring security website claims that spring security is compatible with 3.2.0+ of spring framework. In an OSGi environment, this is not true as spring security bundle manifest attempts spring framework package imports with a version range maximum of 3.2.0. I tried also using spring security 3.2.0M1 and the issue is the same.

        Issue Links

          Activity

          Hide
          Rob Winch added a comment -

          This is a duplicate of SEC-2118

          Show
          Rob Winch added a comment - This is a duplicate of SEC-2118

            People

            • Assignee:
              Rob Winch
              Reporter:
              Jack Rudnick
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: