Uploaded image for project: 'Spring Security'
  1. Spring Security
  2. SEC-2922

Spring Security Core JAR Missing Impl-Version in Mainfest

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 4.0.0
    • 4.0.1
    • Core
    • None

    Description

      I just updated our Maven build to Spring Framework 4.1.6 and Spring Security 4.0.0 and the JAR for Spring Security Core didn't have the Implementation-Version in it.

      This was all it contained:
      Manifest-Version: 1.0

      This causes SpringSecurityCoreVersion to return null as the version.

      Attachments

        Activity

          People

            rwinch Rob Winch
            quantas Andrew Landsverk
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: