Spring Security
  1. Spring Security
  2. SEC-997

Upgrade spring-aws-maven and remove extra repository

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.4
    • Fix Version/s: 3.0.0 M1
    • Component/s: None
    • Labels:
      None

      Description

      When a new version 1.2.4 of spring-aws-maven is released upgrade and remove repository http://s3.amazonaws.com/maven.springframework.org/external from pom

      See SPR-5189

        Issue Links

          Activity

          Hide
          Dave Syer added a comment -

          The aws extension has been in Maven Central for donkey's years at version 2.0.0.RELEASE:

          <extensions>
            <extension>
              <groupId>org.springframework.build.aws</groupId>	    <artifactId>org.springframework.build.aws.maven</artifactId>
              <version>2.0.0.RELEASE</version>
            </extension>
          </extensions>
          

          (No need for any funny s3 repositories.)

          Show
          Dave Syer added a comment - The aws extension has been in Maven Central for donkey's years at version 2.0.0.RELEASE: <extensions> <extension> <groupId>org.springframework.build.aws</groupId> <artifactId>org.springframework.build.aws.maven</artifactId> <version>2.0.0.RELEASE</version> </extension> </extensions> (No need for any funny s3 repositories.)
          Hide
          Luke Taylor added a comment -

          Thanks Dave. I've updated the dependency to point at the 2.0.0.RELEASE version.

          Show
          Luke Taylor added a comment - Thanks Dave. I've updated the dependency to point at the 2.0.0.RELEASE version.

            People

            • Assignee:
              Luke Taylor
              Reporter:
              Carlos Sanchez
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: