Uploaded image for project: 'SX Spring Python'
  1. SX Spring Python
  2. SESPRINGPYTHONPY-96

When making builds, use "." as separator between version and tag; support python 2.4/2.5/2.6

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0.0.GA
    • Component/s: Core
    • Labels:
      None
    • Environment:
      When making builds, it becomes apparent that the RC1, or M1, or BUILD-xyz needs to be part of the version number.

      Description

      Tweak the build scripts, upload scripts, and coily to properly handle this new formatting issue.

        Activity

        Hide
        gregturn Greg Turnquist added a comment -

        Completed changes, and was able to get it working for python 2.4, 2.5, and 2.6. Spent a little time investigating python 3.0, but it was too much at this point in time. Also, the dependent libraries Spring Python uses would have to also be upgraded as well.

        Show
        gregturn Greg Turnquist added a comment - Completed changes, and was able to get it working for python 2.4, 2.5, and 2.6. Spent a little time investigating python 3.0, but it was too much at this point in time. Also, the dependent libraries Spring Python uses would have to also be upgraded as well.

          People

          • Assignee:
            gregturn Greg Turnquist
            Reporter:
            gregturn Greg Turnquist
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1d
              1d
              Remaining:
              Remaining Estimate - 1d
              1d
              Logged:
              Time Spent - Not Specified
              Not Specified