Spring for Apache Hadoop
  1. Spring for Apache Hadoop
  2. SHDP-130

DistributedCacheFactoryBean closes filesystem causing hadoop 2.x app to fail

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Complete
    • Affects Version/s: 1.0.0.GA
    • Fix Version/s: 1.0.1.GA, 2.0.0.M1
    • Component/s: FS
    • Labels:

      Description

      DistributedCacheFactoryBean in afterPropertiesSet creates and closes filsystem instance. because in hadoop 2 filesystem instance are singletons, further talking to hdfs is not possible.

      fix is simple: in DistributedCacheFactoryBean change line 117 to

      HdfsResourceLoader loader = new HdfsResourceLoader(fs);

      its regression from RC1, please fix it asap.

        Activity

        Radim Kolar added a comment -

        Its still not fixed in 1.0.1RC1


          People

          • Assignee:
            Thomas Risberg
            Reporter:
            Radim Kolar
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: