Uploaded image for project: 'Spring Social'
  1. Spring Social
  2. SOCIAL-300

execution error on 'spring-social-popup' sample

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      WARN : org.springframework.social.connect.web.ConnectController - Exception while handling OAuth2 callback (I/O error: graph.facebook.com; nested exception is java.net.UnknownHostException: graph.facebook.com). Redirecting to facebook connection status page.
      WARN : org.springframework.social.connect.web.ConnectController - Exception while handling OAuth2 callback (I/O error: graph.facebook.com; nested exception is java.net.UnknownHostException: graph.facebook.com). Redirecting to facebook connection status page.
      WARN : org.springframework.social.connect.web.ConnectController - Exception while handling OAuth2 callback (I/O error: graph.facebook.com; nested exception is java.net.UnknownHostException: graph.facebook.com). Redirecting to facebook connection status page.

        Activity

        akashmishra17 Akash Mishra added a comment -

        I am also getting the same error, when I am trying to login into FB it is redirecting to http://localhost:8080/xyzx/signin?error=provider page, what can be a problem?

        habuma Craig Walls added a comment -

        There's no way for sure of knowing what the root of the problem is, because I don't know the network you are on. But it's clear from the exception that the host known as graph.facebook.com is unknown.

        That host is the host where Facebook's Graph API resides, so that's correct. But for some reason your app can't see that. It could be a firewall problem, it could be a DNS problem, or it could be any number of other network issues that prevent your app from resolving graph.facebook.com.

        Quick test: From the same machine where the app is running, can you open a browser and go to https://graph.facebook.com ? When you do that do you see the following JSON in your browser?

        {
           "error": {
              "message": "Unsupported get request",
              "type": "GraphMethodException",
              "code": 100
           }
        }

        If you see it in your browser, but your app still doesn't work, then it's likely a firewall/proxy issue. Your browser is probably configured to get through the proxy, but your app is not. If your browser can't even see it, then it's likely some other network issue.

        habuma Craig Walls added a comment -

        I ran through all of the Spring Social examples today, including the popup example. I did not encounter any issues. If this issue still exists for the original poster, it's probably a network configuration detail (such as a proxy preventing it from working).


          People

          • Assignee:
            habuma Craig Walls
            Reporter:
            iamkittu krishna
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: